1. ホームペー
  2. 使い方 Blocs
  3. 設計
  4. メニューマネージャー

メニューマネージャー

In Blocs 同期されたメニューデータを使用することができます。つまり、同じデータセットを使用して、プロジェクト全体で複数のメニューを強化できます。 ザ・ Blocs メニューマネージャを使用すると、これらのメニューのデータと構造を管理できます。

すべて Blocs プロジェクトには、自動的に作成されるデフォルトメニューがあり、このメニューの名前は メインメニュー。 プライマリメニューは、プロジェクトで使用されるナビゲーションにデータをフィードするために使用されるメニューです。 プロジェクトのナビゲーションデータをフィードするためにプライマリメニューを使用することは必須ではありません。詳細については、ページのさらに下にあるリストデータソースの設定を参照してください。

メニューマネージャーを開く

メニューマネージャを開くには、に移動します ウィンドウ>メニューマネージャー アプリのメインメニューから、またはキーボードショートカットを使用します ⌘+ 9.

メニュー-マネージャー-メニュー

メニューの追加と削除

メニューマネージャを使用したメニューの追加と削除は非常に簡単です。 メニューマネージャウィンドウの上部に、ラベルの付いたドロップダウンボタンがあります 選択。 このボタンをクリックすると、現在のプロジェクトのすべてのメニューを含むリストが表示されます。 このリストの下部には、ラベルが付いた追加のオプションもあります 新しいメニューを追加。 これを選択すると、プロジェクトに新しいメニューが追加され、メニューマネージャーで編集できるように自動的にアクティブになります。

新規追加メニュー

メニュー項目の追加と削除

メニューマネージャを使用したメニュー項目の追加と削除も非常に簡単です。 ラベルの付いた入力フィールドの下 メニュータイトル XNUMXつのボタンがあり、XNUMXつは 記号とでマークされたもの + シンボル。 でマークされたボタン シンボルは、現在選択されているメニュー項目を削除します。 左クリック とマークされたボタン + あるときに新しいメニュー項目を追加します 左クリック.

ドロップダウンディバイダーアイテム

メニューマネージャを使用すると、さまざまなメニュー項目タイプを挿入できます。 注意:ドロップダウンディバイダーは、データフィードがドロップダウンメニューリストに適用されている場合にのみ表示され、標準メニューには表示されません。

追加メニュー項目

メニュー項目の編集

メニューマネージャからメニュー項目を編集するには、単に 左クリック 編集するメニュー項目リストエントリの右端にある小さな設定記号、または編集するメニュー項目リストエントリの任意の場所をダブルクリックします。 これらのいずれかを実行すると、メニュー項目エディタシートが開きます。

編集メニュー項目

メニューを削除

メニューマネージャからメニューを削除するには、単に 左クリック ドロップダウンメニューの右端にある小さな十字記号は、 選択。 プライマリメニューは削除できませんのでご注意ください。

削除メニュー

リストデータソースの設定

のリストアイテム Blocs MenuManagerで作成された任意のメニューからデータを供給することができます。 メニューデータをリストにフィードするには、最初にメインキャンバスでリストオブジェクトを選択し、次にサイドバーオプションから、ラベルの付いたセクションに移動します。 且つ ドロップダウンオプションを、データを提供するメニューに設定します。 今後、このメニューデータがメニューマネージャを介して変更されると、その変更はこのメニューデータに接続されているすべてのリストに自動的に反映されます。

選択データソース

選択メニュー データ ソース

リストのデータソースを更新する

リストのデータソースを更新するには、[データソース]ドロップダウンボタンの左側にある[更新]ボタンを左クリックします。

同期メニューデータの私たち?

メニューのXNUMXつが同期しなくなり、最新の変更が表示されなくなった場合は、次の手順に従ってください。 トラブルシューティングガイド この問題の修正について。

20年2019月XNUMX日に更新

この記事は役に立ちましたか?

関連記事